Jump to content








Welcome to Ford Escape Forum


Sign In 

Create Account
Welcome to Ford Escape Forum, like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Escape Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo
- - - - -

Does Cruise Control belong here?

cruise control

  • Please log in to reply
No replies to this topic

#1 OFFLINE   MattieB

MattieB

    New Escape Member

  • Escape Member
  • 1 posts
  • Region:U.S. Pacific Coast
  • LocationSacramento, California
  • Current Vehicle:2006 Escape B6

Posted 26 March 2015 - 10:01 AM

Hello, everyone.  I"m new both to the forums and to owning a Ford escape.  It's an older one, a 2006.  I got it for my wife, she has always loved SUVs.  I have to say, I do like this one.  It drives really great, especially for being 10 years old.  Here's the thing.  The cruise control worked fine for a couple of weeks, then just stopped.  A few days later, it worked fine for another several days but stopped and hasn't worked for the last 2 weeks.  I ran the diagnostic I came across on other boards, parking brake, hold off, put key in run, etc...  It does flash to indicate that it's in diagnostic mode, then doesn't flash again.  I assume that equates to the "entire system" fault.  What the heck does that mean and what does it entail?  I was ok with replacing a switch under the brake pedal and even figured I could replace the one on the master cylinder, though I am a LONG way from being mechanically inclined.  (I'm a computer tech by trade, if it doesn't involve a keyboard, I'm terrible at it.)  It seems strange that if the entire system were broken, it would have spurts of working fine, but what do I know?  Any thoughts on how I should proceed that don't involve me going to a pro?














Privacy Policy Terms of Service ·