Jump to content








Welcome to Ford Escape Forum


Sign In 

Create Account
Welcome to Ford Escape Forum, like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Escape Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo
- - - - -

Fog lights


  • Please log in to reply
No replies to this topic

#1 OFFLINE   Steved30

Steved30

    New Escape Member

  • Escape Member
  • 1 posts
  • Region:U.S. Northeast
  • LocationOhio
  • Current Vehicle:2007 Ford Escape 3.0 4wd

Posted 18 April 2015 - 07:09 PM

I recently purchased a 2007 Ford Escape 3.0 4wd. The fog lights did not come on so I purchaced new bulbs. When I went to replace them I noticed that they were unplugged. I reconnected them and they worked. After I reconnected the lights I noticed a few differences, the chime was different when I turned the key, the doors will no longer automatically lock when moving forward, the dome lights stay on for atleast a couple of minutes while driving and when I use the key fob to lock the doors and set the alarm the horn honks twice when it used to honk once. There might be other differences that I haven't noticed yet but I don't want to drive it to much until I find out what this is. Any help would be appreciated.












Privacy Policy Terms of Service ·