Jump to content








Welcome to Ford Escape Forum


Sign In 

Create Account
Welcome to Ford Escape Forum, like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Escape Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo

Stripped Lugs... Ford issue?

lugs

  • Please log in to reply
3 replies to this topic

#1 OFFLINE   Illbuyajeepnexttime

Illbuyajeepnexttime

    New Escape Member

  • Escape Member
  • 1 posts
  • Region:U.S. Great Lakes
  • LocationWi
  • Current Vehicle:2013 escape

Posted 10 July 2015 - 09:08 AM

Lug

Edited by Illbuyajeepnexttime, 11 July 2015 - 04:12 AM.


#2 OFFLINE   robertlane

robertlane

    New Escape Member

  • Moderators
  • 142 posts
  • Region:U.S. Great Lakes
  • LocationMI
  • Current Vehicle:E350, GT500

Posted 22 July 2015 - 03:55 PM

Try to insist that your shop use anti-seeze lube on your lug studs.


Ford Escape Forum

Quick Tutorial Help

Forum Software Guide

#3 OFFLINE   Tucker

Tucker

    New Escape Member

  • Escape Member
  • 71 posts
  • Region:Decline

Posted 03 August 2015 - 07:32 AM

did you get it fixed?



#4 OFFLINE   elgino26

elgino26

    New Escape Member

  • Escape Member
  • 1 posts
  • Region:U.S. Northeast
  • LocationMaine
  • Current Vehicle:2008 Ford Escape AWD 3.0

Posted 10 September 2016 - 10:34 AM

Yes, common problem. They use inferior aluminum (I think) lugs. Just had to get lugs replaced on a 2013 Explorer company vehicle - same problem.














Privacy Policy Terms of Service ·