Jump to content








Welcome to Ford Escape Forum


Sign In 

Create Account
Welcome to Ford Escape Forum, like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Escape Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo
- - - - -

not cooling well after new compressor installed

new compressor installed by dealer now not cooling

  • Please log in to reply
2 replies to this topic

#1 OFFLINE   tlzfixer

tlzfixer

    New Escape Member

  • Escape Member
  • 1 posts
  • Region:U.S. Northeast
  • LocationLatrobe PA
  • Current Vehicle:2006 ford escape limited

Posted 13 July 2015 - 02:05 AM

Hi guys,  two weeks ago my local Ford dealer installed a new compressor for my a/c [covered under an extended waranty sold by that dealer for an external company].  The original complaint was it needed recharging every few months.  The Ford Service diagnosis was "found compressor shaft leaking and orifice tube had debris, evac and recharge and replaced compressor and orifice and flushed out lines".  The a/c cooled great for two days, then when I pulled up to a stop light it became warm [it was 80 degrees outside].  The compressor was still running but not cooling.  The next day the a/c was cool but not cold.  When taken to the dealer, the mechanic stuck his finger in front of the vent and said it was fine.  Thanx for letting me vent.  Any suggestion how to get this fixed without going to extremes.  The dealer won't do anything.



#2 OFFLINE   Tucker

Tucker

    New Escape Member

  • Escape Member
  • 71 posts
  • Region:Decline

Posted 03 August 2015 - 07:34 AM

The shop should look into that does not seem right



#3 OFFLINE   deerlake

deerlake

    New Escape Member

  • Escape Member
  • 9 posts
  • Region:Canada Ontario
  • Locationhome
  • Current Vehicle:2010 Ford Escape 4 cyl

Posted 13 June 2017 - 01:45 PM

so what happened? that sounds like a typical response. it should be really cold air.














Privacy Policy Terms of Service ·