Jump to content








Welcome to Ford Escape Forum


Sign In 

Create Account
Welcome to Ford Escape Forum, like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Escape Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo
- - - - -

Replacing my license plate lights with LED


  • Please log in to reply
No replies to this topic

#1 OFFLINE   skullmurphy

skullmurphy

    New Escape Member

  • Escape Member
  • 2 posts
  • Region:U.S. Great Lakes
  • LocationUnited States
  • Current Vehicle:2014 Escape Titanium

Posted 31 October 2015 - 09:02 AM

Hello all, I have a question, I have a 2014 escape titanium and wanted to replace my rear license plate lights with the LED ones.

Well I replaced them and they do work BUT when the timer goes off the LED lights are sill lit ( dimly ) but still lit. So it still has voltage running through the harness. I asked my dealer why Ford did not put LED's on the escape when the fusion has them but he could not give me an answer. So I am wondering if the harness need a resistor installed in it to work. Just want to see if anyone knows why.














Privacy Policy Terms of Service ·