Jump to content








Welcome to Ford Escape Forum


Sign In 

Create Account
Welcome to Ford Escape Forum, like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Escape Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo
- - - - -

Oil Warning Indicator At Idle In Gear Flickers

2002 escape auto

  • Please log in to reply
1 reply to this topic

#1 OFFLINE   jlentriken

jlentriken

    New Escape Member

  • Escape Member
  • 4 posts
  • Region:Australia and Oceania
  • LocationPerth
  • Current Vehicle:Nissan 300ZX Z32

Posted 27 December 2015 - 05:56 AM

Having some issues with my ford.

I recently purchased it with a wrecked gearbox - I've learned its was an issue with the years model.

I put a new box in, no dramas, but when i gave it a general service, i put in factory spec oil. 
First 5w20, then i realised the Australian delivered model says 5w30. I realised this when at idle in gear at operating temperatures, and sometimes in neutral or park, the oil light flickers on. Naturally i quickly changed the oil to the 5w30, new oil filters both times. The issue persisted, so i talked to a few other mechanics and they suggested putting in 10w40 as its not a new car after all. (about 200k km on the clock).

The problem persists though! its much better, but when in gear at idle it still starts to flicker on and off.

Now prior to the oil change it wasn't happening. So I'm not sure whats going on?

Ive seen many people have this issue online, but no fixes. Any ideas?

Other than the oil light it runs great.

 

2002 Ford Escape Auto



#2 OFFLINE   jlentriken

jlentriken

    New Escape Member

  • Escape Member
  • 4 posts
  • Region:Australia and Oceania
  • LocationPerth
  • Current Vehicle:Nissan 300ZX Z32

Posted 27 December 2015 - 09:15 PM

Is this forum even active?














Privacy Policy Terms of Service ·