Jump to content








Welcome to Ford Escape Forum


Sign In 

Create Account
Welcome to Ford Escape Forum, like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Escape Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo
- - - - -

Left side turn signal and brake light problem on 2010 & 2012


  • Please log in to reply
1 reply to this topic

#1 OFFLINE   jmalek

jmalek

    New Escape Member

  • Escape Member
  • 1 posts
  • Region:Decline
  • LocationNorth Carolina
  • Current Vehicle:2010 and 2012 Escape

Posted 27 August 2016 - 07:18 AM

On four or five separate occasions over the past year the left turn signal and brake light has stopped working on BOTH of my 2010 and 2012 Escapes. However in the past it will then begin randomly working again a few days later. The bulb is not burned out, and it always occurs on the left side, so far never on the right.  It happened again a month ago on the 2012, but so far it hasn't begun working again, so I need to figure out what the root problem is.

 

Any ideas what the cause may be? Perhaps a relay??



#2 OFFLINE   Thelegend

Thelegend

    New Escape Member

  • Escape Member
  • 94 posts
  • Region:Decline

Posted 27 August 2016 - 05:57 PM

sorry I can't help hopefuly someone else has answer














Privacy Policy Terms of Service ·