Jump to content








Welcome to Ford Escape Forum


Sign In 

Create Account
Welcome to Ford Escape Forum, like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Escape Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo
- - - - -

Blinkers randomly turn on, stay on Control Module?


  • Please log in to reply
1 reply to this topic

#1 OFFLINE   08MarinerNH

08MarinerNH

    New Escape Member

  • Escape Member
  • 2 posts
  • Region:U.S. Northeast
  • LocationNH
  • Current Vehicle:2016 Titanium / 2008 Mariner

Posted 28 April 2017 - 06:20 PM

Hi guys,

   I have an 08 Mariner.. Great car, just has the issue with the blinkers randomly turning on, and staying on, even when switch is in the off position.

 

Some times the right blinker will flash in the right blinker position, and the off position on the switch.  The left blinker position will shut the blinker off, but left blinker wont work.   

 

Sometimes it works normally, but the right blinker will randomly blink a few times.  I know it's probably the body control/fuse box that needs replacing, but is my only option involve a dealership flashing it?  

 

Also, if I get a used one, could there be any problems associated with that?  New ones are about $260 and i'd rather roll the dice on a $50 part..

 

If anyone has suggestions on how to resolve this issue, in the cheapest/easiest way, i'm all ears.

 

Thanks,

  George



#2 OFFLINE   08MarinerNH

08MarinerNH

    New Escape Member

  • Escape Member
  • 2 posts
  • Region:U.S. Northeast
  • LocationNH
  • Current Vehicle:2016 Titanium / 2008 Mariner

Posted 29 April 2017 - 03:50 PM

I couldn't handle it anymore.  Went to a local junk yard, and took the Smart Junction Box out of an Escape of the same year.. Plugged it in, and my problem is gone, and looks like I can avoid going to the dealer.  The numbers did not match perfectly.  Same replacement part number on the box, but mine ended with A and the one I put in had a B.  

 

Still worked great! 














Privacy Policy Terms of Service ·