Jump to content








Welcome to Ford Escape Forum


Sign In 

Create Account
Welcome to Ford Escape Forum, like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Escape Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo

Front end clunking


  • Please log in to reply
3 replies to this topic

#1 OFFLINE   JKarhansen

JKarhansen

    New Escape Member

  • Escape Member
  • 1 posts
  • LocationUtah
  • Current Vehicle:2003 Ford Escape

Posted 29 January 2012 - 06:27 PM

I have a 2003 Escape. I have a clunking noise coming from the front end. I have replaced the Struts and also the Strut Mounts. I am still getting the same clunk when i
hit just normal street bumps and pot holes. I was hoping someone has had the same issues. I have checked the sway arm bushings and the sway bar bushings and the sway bar linkage but I have not replaced them. My next step will be the control arm bushings.
Thanks,
Jess

#2 OFFLINE   KKO

KKO

    New Escape Member

  • Escape Member
  • 4 posts
  • LocationWesley Chapel Fl
  • Current Vehicle:2012 Ford Escape XLT Sport

Posted 28 May 2012 - 03:49 AM

I would check the sway bar links close. Those are the most common fialure. Take them loose and see how much play they have in them. I bet they are your issue.

Edited by KKO, 28 May 2012 - 03:51 AM.

  • robertlane likes this

#3 OFFLINE   robertlane

robertlane

    New Escape Member

  • Moderators
  • 142 posts
  • Region:U.S. Great Lakes
  • LocationMI
  • Current Vehicle:E350, GT500

Posted 03 June 2012 - 11:41 AM

I would check the sway bar links close. Those are the most common fialure. Take them loose and see how much play they have in them. I bet they are your issue.


Sway bar links and attachment points are common failures in all vehicles.
Ford Escape Forum

Quick Tutorial Help

Forum Software Guide

#4 OFFLINE   jerrymack

jerrymack

    New Escape Member

  • Escape Member
  • 3 posts
  • Region:U.S. Pacific Coast
  • LocationUnited States
  • Current Vehicle:Ford Escape Hybrid 4WD 2007

Posted 21 April 2014 - 04:13 PM

Hello.  I have a 2007 Hybrid. It is making the same clunking noises when I hit small bumps.  There was a factory bulletin regarding the roll stabilizer (what you are calling the "sway bar") links recommendingt that they be replaced with a heavier duty model.  I did purchase and install those links.  This was quite a while before I started noticing this clunking noise which I only noticed about a month ago.  I suppose it could be that the ball joint ends of the new ones got loose too, but this is disappointing if it is the case.

 

Anybody else out there having this problem?














Privacy Policy Terms of Service ·