Jump to content

Alphalimaromeo

Escape Member
  • Content Count

    3
  • Joined

  • Last visited

About Alphalimaromeo

  • Rank
    New Escape Member

Profile Information

  • Region
    U.S. Mississippi Valley
  • Location
    Arkansas (AR)
  • Current Vehicle
    2002 and 2010 escapes
  1. Alphalimaromeo

    C4DE issue

    I have a question about what's going on with my first gen. It's a 2002 xlt v6 auto 4x4. 122xxx miles. 1. The Torque convertor lockup in 4th is pretty rough. I've heard that this is from the convertor slipping on lock up and pretty common. With OD off it's not nearly as noticable but that could be from the RPM difference. 2. Recently, when it locks it will sometimes make a scraping type sound or hesitate to lock. It feels like a gear slip. I've owned it for less than a year so the maintenance history is not know but everything looks like it was babied by the P.O. anyone have this issue that could point me where to start? I love my car and would rather not rip the gears up or something.
  2. Alphalimaromeo

    02 transmission

    I have a question about what's going on with my first gen. It's a 2002 xlt v6 auto 4x4. 122xxx miles. 1. The Torque convertor lockup in 4th is pretty rough. I've heard that this is from the convertor slipping on lock up and pretty common. With OD off it's not nearly as noticable but that could be from the RPM difference. 2. Recently, when it locks it will sometimes make a scraping type sound or hesitate to lock. It feels like a gear slip. I've owned it for less than a year so the maintenance history is not known but everything looks like it was babied by the P.O. anyone have this issue that could point me where to start? I love my car and would rather not rip the gears up or something.
  3. Alphalimaromeo

    Hello

    Hi everyone. New to the forum. I have a 2002 xlt v6 4x4, 122000 miles and a 2010 xlt fwd 174000 miles. Just saying hi.
×