Jump to content
Sign in to follow this  

2017 Escape - Remote Start Not Working

Recommended Posts

Sorry if this is an issue already posted as I am a new Escape owner and new to this site.  I just purchased a 2017 Escape Titanium and my remote start function on the FOB does not result in anything when I depress the appropriate button 2x.  I've had the vehicle for 2 weeks now and recall (vaguely) that it did work at one time when I tried it shortly after taking delivery.  In fact my wife reminded me that the salesperson actually used the feature to start the vehicle when we were ready to take possession.  I've tried some research online but only find reference to "remote start settings" on these Escapes, presumably through the main menu on the dash, but no particulars after that.  I am wondering if something got reset on my part, although I haven't really done much with the electronics on this vehicle other than setting up my cell phone interface with the Sync 3 system.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this