Jump to content


Bruce's Dad

Newbie here

Recommended Posts

Hi.  I'm Bruce's Dad.  I'm new to the forum.  Bruce is my 2 year old Mastiff.  I bought my 04 Escape 3 weeks ago to haul him and the other dogs around.  It has 82K miles on it.  I paid $800 for it.  Would you believe no rust?  in Missouri?  4 cylinder.  4X4.  Runs like a champ.  A few minor dings, not real dents.  Not the prettiest, but it does what I need.  I also own a 13 Chevy Volt with 30K miles (which my son let's me drive occasionally), a 13 Prius with 130K (which my daughter stole and took to TX), and a 99 BMW Z3 with 200K.  Bruce does not fit in it.

So my issue is tonight, while sitting in line at Steak n Shake, the Escape started to overheat (1st time it has done that, but I've never had to sit and idle either).  I got her home and started my investigation.  No leaks anywhere.  Lost less than 1 cup of fluid.  Both fans behind the radiator are not running.  I have no literature to tell me where to hunt for relays, etc.  Who can start me in the right direction?

I appreciate the help.

Share this post


Link to post
Share on other sites

Do you have AC? If you do (and it works) you can turn the AC on it will force the electric fans to come on.

Fuse 25 and 26 (both 40A) are the load fuses , there are three relays in the Battery Junction Box that control them (for different speeds) and fuse 9, [inside under dash] (3A) is the fuse for the control side of the relays.

The temperature sensor (two wire) is on the right front of the cylinder head.

Share this post


Link to post
Share on other sites

Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×